Viewing 15 posts - 1 through 15 (of 34 total)
  • Author
    Posts
  • Khanh Le Moderator
    #153208

    Case: Your site install both extensions: T3v2 & Advanced Module Manager.

    Problem: Both extensions override core joomla JModuleHelper class.

    Solution: Merge 2 override into one class.

    I have merged our override part to the class of AMM and attach to this thread. Follow these steps to update your current site.

    1. Download the attachment, copy overwrite file plugins/system/advancedmodules/modulehelper.php.

    2. Open for edit file plugins/system/jat3/core/framework.php, line 25:
    From:

    t3import ('core.joomla.modulehelper');

    To:

    if (!class_exists ('JModuleHelper')) t3import ('core.joomla.modulehelper');

    Update 1: Add checking to ignore override for T3 in modulehelper when in administrator (thank galwen).


    1. modulehelper.zip
    equest Friend
    #357456

    I had spent months in frustration trying to get T3 to work like in the guides…and blank!
    Then I found a thread that mentioned that Advanced Module Manager and T3 don’t go together – I tested it out by disabling AMM and found that T3 now worked fine. However, was devastated as I rely heavily on AMM and need BOTH!

    Am so glad to have found this solution – it works great!
    Thank you khanh le!

    I don’t quite understand this line, though:
    <blockquote>Update 1: Add checking to ignore override for T3 in modulehelper when in administrator</blockquote>

    Is this already in the solved code or does anything more need to be added?

    Khanh Le Moderator
    #357457

    <em>@equest 196526 wrote:</em><blockquote>
    Is this already in the solved code or does anything more need to be added?</blockquote>
    Already in the solved code.

    equest Friend
    #357468

    Thank you! 😀

    socoweb Friend
    #358658

    it’s not always line 25.

    If you update with the NoNumber Extension Manager, you will need to update the moduleshelper.php file again!

    thomascollado Friend
    #362453

    Thanks, that fixed my problem:laugh:

    socoweb Friend
    #362457

    NoNumber has updated the Advanced Module Manager to be compatible with the T3 framework! Thank you Peter!

    http://www.nonumber.nl/extensions/advancedmodulemanager

    Now only the plugins/system/jat3/core/framework.php file needs updated

    Arvind Chauhan Moderator
    #362476

    Guys,

    Its fixed now. T3 plugin 1.2.0 is out. Peter, Stephen and we worked together to solve the issue and they would also be releasing their versions soon.

    thatch10 Friend
    #362831

    Using JA T3 Plugin 1.2.0 and Advanced Module Manager 1.13.0 on 2 sites

    both are now giving the warning – Warning: Missing argument 2 for plgSystemJAT3::onRenderModule() in user/htdocs/plugins/system/jat3.php on line 191

    Reverting Back to modified JA T3 Plugin 1.1.8 removes the warning.

    Khanh Le Moderator
    #362865

    T3 Plugin & Advanced Module Manager both override the core Joomla modulehelper class and cause conflict. We recently work together to resolve this issue. The fix is updated into our latest release for T3 (1.2.0) and will be available in coming update of AMM (v 1.13.1).

    At this time, you can copy file modulehelper.php for T3 v1.2.0 (plugins/system/jat3/core/joomla/modulehelper.php) and override the file in AMM (plugins/system/advancedmodules/modulehelper.php) to solve the problem.

    elvisvinicius Friend
    #362878

    <em>@thatch10 203505 wrote:</em><blockquote>Using JA T3 Plugin 1.2.0 and Advanced Module Manager 1.13.0 on 2 sites

    both are now giving the warning – Warning: Missing argument 2 for plgSystemJAT3::onRenderModule() in user/htdocs/plugins/system/jat3.php on line 191

    Reverting Back to modified JA T3 Plugin 1.1.8 removes the warning.</blockquote>

    Hi. Open the file user/htdocs/plugins/system/jat3.php and at line 191 add the red text:

    function onRenderModule (&$module, $attribs = array()) {

    Now works! 🙂

    (^ ^)

    saladdin19 Friend
    #363314

    <em>@elvisvinicius 203582 wrote:</em><blockquote>Hi. Open the file user/htdocs/plugins/system/jat3.php and at line 191 add the red text:

    function onRenderModule (&$module, $attribs = array()) {

    Now works! 🙂

    (^ ^)</blockquote>

    Thanks Elvisvinicius! :laugh:

    hektorrr Friend
    #371890

    Did You know somethink about using T3 Framework 2 with Panel Sharing?
    You can see that on my site : http://zarabiaczek.pl clicking on any article . Plugin is on but it cant load on page with my articles or content :/
    I Cant fix it alone 🙁

    ihjens Friend
    #375381

    Just if someone should happen to run in the same problem – I installed a T3 Framework based template and installed joomfish and eventually the Advanced Module Manager (AMM). Since the main page wouldn’t load afterwards anymore (error: 500 – no valid db connection) I assumed it would be related to problems with T3 and AMM – however you only need to disable the System – Jfdatabase plugin and enable it afterwards again. Since Joomfish seems a rather popular extension I thought it would be worth mentioning here.

    midsomer Friend
    #375661

    I had this similar issue when I installed JA Social template and the required JAT3 plugin from the latest download.
    Using J1.5.22 , JA Social v1.2.1, JAT3 v1.2.3, AMM v1.9.7

    I got a list of warnings in the backend and frontend <blockquote>Warning: Missing argument 2 for plgSystemJAT3::onRenderModule() in user/htdocs/plugins/system/jat3.php on line 214</blockquote>

    It took a few hours to find this possible fix, which I’m pleased to report did fix it.

    <em>@khanh le 203566 wrote:</em><blockquote>T3 Plugin & Advanced Module Manager both override the core Joomla modulehelper class and cause conflict. We recently work together to resolve this issue. The fix is updated into our latest release for T3 (1.2.0) and will be available in coming update of AMM (v 1.13.1).

    At this time, you can copy file modulehelper.php for T3 v1.2.0 (plugins/system/jat3/core/joomla/modulehelper.php) and override the file in AMM (plugins/system/advancedmodules/modulehelper.php) to solve the problem.</blockquote>

    Replaced the modulehelper.php in the AMM with a copy from JAT3 and it cleared the warnings.

    Hoping to see this fixed in AMM upgrades.

Viewing 15 posts - 1 through 15 (of 34 total)

This topic contains 34 replies, has 23 voices, and was last updated by  Blaine 7 years, 2 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum