Viewing 15 posts - 1 through 15 (of 37 total)
  • Author
    Posts
  • Sherlock Friend
    #127895

    Hi everybody.
    Plz post here every bugs(only bug, not request to modify follow your site) what you have in RS gallery 2, I will check them and update RS gallery2
    Hope can help.

    seandiggins Friend
    #247077

    In the post below there are issues associated with the slider (now apparently fixed) but there are also issues associated with ordering within the gallery. Please refer:

    “Here is the deal as best as I can figure it out. For each gallery to work properly, the items in the gallery need to be ordered from 1 on in full proper sequence. This is how the component behaves if you set the order in the image properties page that comes up if you click on the image name in the image manager. When you do this, you end up with each gallery having a 1, 2, 3, 4 and so on for the image order. However, if you use the arrows in the Image Manager, then it tries to number the image order as one pool of numbers across ALL the galleries, so you will have one gallery starting at 1, and another gallery starting at 15 and another gallery starting at 22 or something like that, because it will not let you have multiple items with the same order number. When this happens, the navigation controls at the bottom of the individual gallery pages will stop working properly. So, if you want the page navigation to work properly, you have to make sure to only order items by the order field in the actual image properties, not with the arrows.

    As far as the problems with the slider, that is even stranger, and even harder to work around. The slider seems to go, not by the order number, but by the position of the image entry in the rsgallery2_files database. So, as far as the slider is concerned, the first image in the the database, has to be the first image in the gallery, regardless of the number in the ordering field. As such, if you have the items in the gallery in any order other than the order they appear as entries in the rsgallery2_files database, then it will go to the wrong page when you click on it. I honestly don’t know why any of the code should care where the entry is in the actual database, since it should be reading the order number, or at least the ID number, not relying on the order they happen to be returned from an SQL query, but that is in fact what it is doing.

    All of these issues basically make the ordering features of RSGallery2 not only completely useless, but actually nothing more than a point of error. You cannot reorder your files, or the slider will get out of sync, and you also have to go in and reset the order every time you upload a new file to the database, or the controls on the individual pages will stop working properly, since the program will automatically try and give the image the next available number for all galleries, thus reordering them all so that there are no shared numbers. As a result, you end up with a ‘feature’ that gives you no usable functionality, and is almost guaranteed to cause errors at some point.”

    Sherlock Friend
    #247091

    Maybe I miss understand your request, but I have tried to update. Plz download this file 1448, then unzip and you will have 2 files is: mod_ja_rssilde.php and display.class.php. Copy overwrite mod_ja_rsslide.php to modulesmod_ja_rsslide folder, copy overwrite display.class.php to componentscom_rsgallery2templatesja_semantic folder
    Hope can help you

    lmlloyd Friend
    #247119

    Yes, that fixes the slider issue completely, as far as I can tell, and also fixes the navigation at the bottom of the gallery pages! Thank you very much for your hard work.

    It seems to all be working as advertised now, at least as far as I’m concerned.

    lmlloyd Friend
    #247123

    Once again, thank you for all your work fixing this component. I have one more bug, that is a much more minor issue than the ones you have already fixed.

    If you have a picture that has a portrait alignment, then when it shows in the front page slider, it fits the width to the window. That is the correct behavior, and that is what the module normally does. However, if the first image to show up on a new page load happens to be portrait alignment, then it will fit the height to the window, instead of width. If you look at another image, and then come back to that image, it will properly show as fitting the width, but on initial page load it fits the height.

    Sherlock Friend
    #247227

    Hi,
    Can you print screen or send your link ? So i can understand your question (my English not good as you)

    itgl72 Friend
    #247402

    <em>@nguoiabcd 50841 wrote:</em><blockquote>Plz download this file 1448, then unzip and you will have 2 files is: mod_ja_rssilde.php and display.class.php. Copy overwrite mod_ja_rsslide.php to modulesmod_ja_rsslide folder, copy overwrite display.class.php to componentscom_rsgallery2templatesja_semantic folder
    Hope can help you</blockquote>

    Can you tell me if these files that are being updated are also being integrated into the TEMPLATE DOWNLOADs? Meaning if I went to download QUICK INSTALL right now would your fixes and updated files already be there?

    or…

    Would someone then have to come here to the forum and download these fixes?

    itgl72 Friend
    #247405

    <em>@nguoiabcd 50841 wrote:</em><blockquote>Maybe I miss understand your request, but I have tried to update. Plz download this file 1448, then unzip and you will have 2 files is: mod_ja_rssilde.php and display.class.php. Copy overwrite mod_ja_rsslide.php to modulesmod_ja_rsslide folder, copy overwrite display.class.php to componentscom_rsgallery2templatesja_semantic folder
    Hope can help you</blockquote>

    I have tried this, check your PM for URL to see error Iam getting. I have not done anything except upload the replacement files.

    Warning: getimagesize(/home/lemoslif/public_html/dev/backup1/images/rsgallery/display/AviatorG 20.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /home/lemoslif/public_html/dev/backup1/modules/mod_ja_rsslide/mod_ja_rsslide.php on line 250

    EDIT EDIT EDIT: This error I am gettin may have something to do with the fact that inside the slider module I selected LINKED IMAGES? to NO. It seems to work when it set to YES, however there is a BUG there that needs to be addressed. It should work both ways I would assume, no?

    Sherlock Friend
    #247455

    Plz wait, now i have a holiday , i will come back at this Sunday

    itgl72 Friend
    #247485

    I would like to add something to this after some testing.

    I uploaded two new images into an existing gallery that had about 70 images.

    The images upload succesfully. When I go to website and click on my gallery link I will see both images as the NEWEST IMAGES when I click on the LATEST link. (Latest link on front page of gallery module or inside the gallery I uploaded the images to.)

    THE PROBLEM? As I click through the gallery these two new images should be LAST. They ended up being the 19th and 20th in the order out of 70 pictures where they should have been last and been the 69th and 70th picture.

    This issue does not happen on the previous version before the FIX.

    lmlloyd Friend
    #247512

    <em>@nguoiabcd 51018 wrote:</em><blockquote>Hi,
    Can you print screen or send your link ? So i can understand your question (my English not good as you)</blockquote>

    See the example here

    jsperl Friend
    #247520

    Ok, here is one item:

    Navigation on image display pages of some galleries broken…see here for example:

    http://76.12.14.108/index.php/component/option,com_rsgallery2/Itemid,88/id,171/page,inline/

    Thanks!

    itgl72 Friend
    #247522

    <em>@jsperl 51414 wrote:</em><blockquote>Ok, here is one item:

    Navigation on image display pages of some galleries broken…see here for example:

    http://76.12.14.108/index.php/component/option,com_rsgallery2/Itemid,88/id,171/page,inline/

    Thanks!</blockquote>

    JSPERL, this thread is for JA Avian & JA Avian II templates. 😀

    jsperl Friend
    #247524

    <em>@itgl72 51417 wrote:</em><blockquote>JSPERL, this thread is for JA Avian & JA Avian II templates. :D</blockquote>

    Does that really matter? This site started as an Avian template which I paid for, fair and square:D
    Though I’ve since switched it to a Rockettheme, I’m still using Joomlart’s version of RSG2. I’m still a Joomlart Club member, and will probably continue to use their templates for future projects.

    nchaleta Friend
    #247547

    When entering the gallery, the pathway only shows 3 levels even if your gallery has more than that.

    Thanks

Viewing 15 posts - 1 through 15 (of 37 total)

This topic contains 37 replies, has 16 voices, and was last updated by  andreipopel 15 years, 5 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum