Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • baujahr70 Friend
    #1081498

    Hello experts,

    I made an override of com_content/vies/form/tmpl/edit.php by copying the edit.php and edit.xml to html/com:content/form folder in the templatefolder of my purityiii installation.

    I only copied and renamed these two files and changed the xml to gt a new menuentry option.

    When I open this override the site isn’t shown correctly and I get an error > 0 – Cannot use object of type ContentViewForm as array

    I allready tried the sollution found at https://www.joomlart.com/forums/topic/bug-found-in-t3-2-6-5/
    but it has no effect to me.

    I know it has something to do with the call > JLayoutHelper::render(‘joomla.edit.params’, $this);

    When I delete the joomla. from joomla.edit.params the site is shown correctly with no error, but all cutom fields are missing.

    Please help me.

    regards,
    BJ70

    @admin_help: you can reach the overrides by clicking on the marked menuitems in off.canvas (see attached picture)


    1. ja_support_1512_1
    baujahr70 Friend
    #1081508

    output off debug console


    1. ja_support_1512_2
    Saguaros Moderator
    #1081819

    Hi,

    I’ve shared this issue with the team for further checking and update. Pls stay tuned.

    Mo0nlight Moderator
    #1082157

    Hi.

    i tried the steps you talking but i don’t see the error.

    Please post your ftp account in private mode. so i could check for you

    baujahr70 Friend
    #1082891
    This reply has been marked as private.
    Mo0nlight Moderator
    #1083102

    Hi.

    You don’t have to override to show joomla custome field.
    It’s already exists.

    See my screenshot.
    I renamed t3/layout edit folder.


    1. Screen-Shot-2017-12-25-at-9.56.03-AM
    2. Screen-Shot-2017-12-25-at-9.56.09-AM
    3. Screen-Shot-2017-12-25-at-9.57.10-AM
    baujahr70 Friend
    #1083344

    which folder did you rename?

    Saguaros Moderator
    #1083347

    This folder: /plugins/system/t3/base-bs3/html/layouts/joomla/edit_

    baujahr70 Friend
    #1083623

    ouch…

    what will happen on next t3 update?
    -I think it’s an system folder…

    Saguaros Moderator
    #1083815

    Pls try to remember this change when you update T3 plugin.

    baujahr70 Friend
    #1083933

    Well, I’ll try to remind myself, but where was the mistake?
    Is it on may side or is it a bug in T3?

    Saguaros Moderator
    #1083977

    Hi,

    Somehow it happens on your site specific so I will report to the team if they can replicate it. If it’s a bug, then there will be update on T3.

    Again, pls backup your site before updating T3 / templates.

    Regards

Viewing 12 posts - 1 through 12 (of 12 total)

This topic contains 11 replies, has 3 voices, and was last updated by  Saguaros 1 year, 7 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum