Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • frippe12573 Friend
    #1048461

    Hi all,

    I’m using Purity III joomla template. I want to set up the multilingual capability. To such aim I followed this guide: https://www.joomlart.com/forums/topic/how-to-add-language-switcher/

    I created the module ‘languageswitcher’, and I enabled the two plugin, language filter and language code. I installed then the second languages and I edited the ‘Content Language’.

    I was expecting that at least the two flags would have been visible replacing the search box in the top menu, but actually I cannot see the two flags.

    What is the reason? Could you give me hints?

    Best

    Eugenio

    Pankaj Sharma Moderator
    #1048962

    Hi
    Kindly follow this documentation to create a multi-language website.
    Hope it helps.

    Regards

    frippe12573 Friend
    #1080932

    Hi,

    as you suggested I followed the documentation you pointed me.
    I think I’m almost at the end but something is still going wrong.
    I have a global menu for all languages with only the Home item,
    and two menu, one for Italian and the other for English including
    the items needed. The content connected to the menus are existing
    in both languages and are associated.
    Then I disabled the main menu module, and I set the position for the two menus
    at mainnav.
    However, I cannot display the menus, I only see the the Home button, which I
    think it is referred to the main global menu.
    Am I right? What is wrong?
    Of course I set the languages switcher in the languagesswitcher position,
    and the two flag are visible.

    Could you give me an hint?

    best

    Eugenio

    Pankaj Sharma Moderator
    #1081031

    Hi
    If you are not using the Megamenu in the template and using menu via module you have to use two different menu module that will show these two language menu items.

    If you will use Megamenu in the template you can copy the template style and choose megamenu for each template style and assigned them to the different language menu items.

    This way you will get the different menu for different languages.

    Regards

    frippe12573 Friend
    #1081115

    Hi,

    I’m in the first case: mega menu is not enabled.
    However, I have already two different modules for the two menus.
    The position of both is mainnav, but in the purity III default template
    there is not mainnav in the layout, but mainmenu.

    That could be the problem?

    E.

    Pankaj Sharma Moderator
    #1081125

    Hi
    KIndly use two different template style and choose the Menu from template option, this will help you to display menu for each language pages.
    Regards

    maryhaugen Friend
    #1081126

    Can I make different urls for each language?
    I see some extensions for store switcher, is it relative?

    I am so cool

    Pankaj Sharma Moderator
    #1081137

    Multilanguage switcher non visible

    Hi Kindly open a separate thread for your topic, add subject and complete question details in it,
    So we can assist you better.

    Regards

    frippe12573 Friend
    #1081142

    Hi,

    I think I have solved the problem! Just to understand if I did well this is the current state:

    I have a style (default) where the menu assigned is for language1 in navigation tab and I copied the same style and named default 2 where the menu assigned is for language2. For both styles I turned on all the relative pages of each menu.

    Did I do well?
    My doubt is if would have to create a third style: one for the default menu, one for language1 and one for language2.

    Thanks,

    Eugenio

    • This reply was modified 2 months, 1 week ago by  frippe12573.
    Pankaj Sharma Moderator
    #1081330

    Hi
    The default menu style will use one language so you can use any of the template syle on it.
    There is no issue.

    Regards

Viewing 10 posts - 1 through 10 (of 10 total)

This topic contains 9 replies, has 3 voices, and was last updated by  Pankaj Sharma 2 months, 1 week ago.

You must be logged in to reply to this topic.