Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • jobbers67 Friend
    #1039103

    Hi, Im getting the error message showing on the public pages of the website when upgrading to PHP7

    "Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; JAT3_AdminUtil has a deprecated constructor in /homepages/7/d500699608/htdocs/test2/plugins/system/jat3/jat3/core/admin/util.php on line 21"

    The Server Error Reports setting is set to None but this still shows on all the public pages

    This is on a copy / test site from a live site that is working fine on PHP 5.6 so will need to be able to transfer the fix to the main site

    Please advise

    Pankaj Sharma Moderator
    #1039349

    Hi
    JA T3v2 System Plugin is not ready for the latest Joomla at this time.
    Kindly wait for the for an update for the plugin, while you can add the issue on our Joomla update status thread here so we can test and fix it during the updates.

    Regards

    jobbers67 Friend
    #1044180

    Any update on this – have looked through the Joomla update thread (all 11 pages) and can’t see anything

    Pankaj Sharma Moderator
    #1044589

    Hi
    You have to wait for the JAT3 v2 update, you can check our blog posts and subscribe newsletter to get the updates and news.

    Regards

    jobbers67 Friend
    #1049255

    Hi, as requested I waited for the update to the plugin that was released on 30 June 2017 so now I am running the version 2.7.4

    Having updated the plugin I updated the PHP from version 5.6 to 7.0 but we are still getting the error –
    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; JAT3_AdminUtil has a deprecated constructor in /homepages/7/d500699608/htdocs/suhockey/plugins/system/jat3/jat3/core/admin/util.php on line 21

    You still appear to have an issue here??

    Pankaj Sharma Moderator
    #1049317

    Hi
    These are the PHP warning only. Go to System > Global configurations > Set the error report to NONE.
    save settings and check.
    It will not create any issue in the working of the plugin.
    Regards

    jobbers67 Friend
    #1049483

    Afraid that setting was already set to "NONE" and the error is still showing
    Any other advice?

    Pankaj Sharma Moderator
    #1049647

    Hi
    The error report set to None should work.Can you check it with hosting to turn off PHP warning?
    Also let e kniw which template you are using i will test it at my end too.
    Regards

    jobbers67 Friend
    #1050712

    Hi,

    I am using the JA T3 Framework plugin (Latest version) alongside a 3rd party template using Shape5_vertex

    Pankaj Sharma Moderator
    #1050886

    Hi
    Can you please read my last reply again and let me know which Joomlart template you are using so i can replicate this issue and see how it goes on fresh package? And ask the hosting provider too.
    If you are using a 3rd party template you have to contact the template provider for the template support.

    Regards

Viewing 10 posts - 1 through 10 (of 10 total)

This topic contains 9 replies, has 2 voices, and was last updated by  Pankaj Sharma 1 year ago.

We moved to new unified forum. Please post all new support queries in our New Forum