Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • xiondesigns Friend
    #175638

    Hi!

    I need some fix for the following errror:

    Fatal error: Cannot redeclare class Browser in /Applications/XAMPP/xamppfiles/htdocs/site/plugins/system/jat3/jat3/core/libs/Browser.php on line 139

    Im using XAMPP on OSX. With Joomla 2.5 and T3 Blank Template.

    i have been working perfectly with T3 for 1.5, and now i have this error, i have checked previous post’s but none of thos fixe’s work for me.

    Any ideas? i need some solution urgently.

    Thanks

    Manos Moderator
    #446803

    Hi,

    Please rename the file Browser.php to browser.php and also let me know the php version you have on xampp

    Regards

    xiondesigns Friend
    #446853

    Hi, im using T3 Plugin v2.5.1 and the file “browser.php” its already in lowercase

    Im using: PHP Version 5.3.1 (Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1)

    xiondesigns Friend
    #446867

    Any ideas?

    I have already tried the rights to read and write for all the files inside that website’s folder as i always do, so i cant understund if not being able to write something is the problem (as stated on other similar post’s).

    Thanks

    xiondesigns Friend
    #447004

    Please, dont let this question die… its probably that many other user’s are getting the same problem.

    I would want to have to change to windows again just for this.

    It worked ok on T3 and Joomla 1.5, why cant you make it work on 2.5 (to the Joomlart staff…)

    Manos Moderator
    #447066

    Hello,

    Is there a way i can access your website and try to help you ?
    I just tested this on localhost using xampp and it’s working (using php 5.2.9)

    xiondesigns Friend
    #447072

    If you have any way (like TeamViewer or something like that that you would recommend… But it’s on localhost. so that kind of solution would be the only one.

    But are you in OSX or windows? My problem is on a mac.

    chavan Friend
    #447266

    Hi xiondesigns

    You open file plugins/system/jat3/jat3/base-themes/default/blocks/usertools/layout-switcher.php and change line 17 from


    t3import ('core.libs.Browser');

    to


    t3import ('core.libs.browser');

    Save it and test your site again.

    Thanks!

    deridjian Friend
    #447350

    <em>@xiondesigns 311438 wrote:</em><blockquote>
    Fatal error: Cannot redeclare class Browser in /Applications/XAMPP/xamppfiles/htdocs/site/plugins/system/jat3/jat3/core/libs/Browser.php on line 139

    Im using XAMPP on OSX. With Joomla 2.5 and T3 Blank Template.
    </blockquote>

    I’m having the exact same problem on the same line. Checked the browser.php on line 139 and it looked normal to me. My knowledge of php is very minimalistic tho.
    I’m on OSX Lion 10.7.3. with Xampp for this very OSX and a local installation of Joomla 2.5.4. T3 plugin activated, blank Template activated. Gives the above fatal error.
    This is driving me nuts.
    Any help would be greatly appreciated.

    xiondesigns Friend
    #447375

    Im using OSX10.6.8 , but i think it just might happen on every mac.

    Come on Joomlart!, give us some help with this! 🙂

    Manos Moderator
    #447383

    Well we are trying and you can tell that for sure! I mean i am here and one of our dev’s is here and we are trying to figure this out.
    First let me say this, i don’t think that has anything to do with the OS of your computer ….and this is why, even if you run this on a Linux computer or Windows or MAC OS …you are still running a web server on it, and php, apache, mySql are still the same.

    So i can’t really figure out why you are facing those issues while at the same time most of our dev’s, as far as i know run MAC’s. I just believe that there’s an issue with your server (localhost server) configurations, and i am still trying even though i messed my setup quite a few times to figure out why this is happening.

    So rest assure that we are trying to help you because here is JA 😎

    deridjian Friend
    #447417

    Maybe it helps if I tell you some more details then. After installing a clean Xampp I did change security (passwords for: phpMyAdmin-User, for MySQL root and for FTP; both Xampp and MySQL are not available via network). Should not affect anything tho, should it?
    Then here comes some version numbers:

    MySQL

    • Localhost via UNIX socket
    • Version: 5.1.44
    • Protocoll Version: 10
    • MySQL-Charset: UTF-8 Unicode (utf8)

    Webserver

    • Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1
    • MySQL-Client-Version: 5.1.44
    • PHP Extension: mysql

    phpMyAdmin

    • Version information: 3.2.4

    Upon installing Joomla locally I chose “MySQLi” as database type, should I rather choose “MySQL”? Does this change anything important?
    After the clean Joomla_2.5.3-Stable-Full_Package I then updated the Joomla Installation itself to 2.5.4 and installed the german language extension through “Discover” (because it didn’t appear after uploading the .zip; quite strange there actually). After that I continued with the “ja_t3_blank.v2.5.0.zip” and directly after that with the “plg_system_jat3.v2.5.1.zip”.

    Last but not least: I changed the database name to the one according to my webspace in advance. That’s all things that shouldn’t have any effect tho IMO?

    Hope this bit of information can help your brainstorm session!
    Greetings

    Marian

    Manos Moderator
    #447428

    Hi,

    Please delete all the files from the JA T3 plugin and reinstall from a fresh copy. It’s important that you delete all the plugin files before installing the plugin again!

    Please let us know if that solves the problem.

    chavan Friend
    #447430
    deridjian Friend
    #447441

    <em>@Do Ha 312420 wrote:</em><blockquote>Hi all

    The answer in this thread that I posted yesterday

    http://www.joomlart.com/forums/topic/cannot-redeclare-class-browser-in-t3-blank-with-osx-and-xampp/#post-447266

    Thanks!</blockquote>

    Structure well investigated! Thank you very much sir! 🙂
    I suppose this will be changed asap in the release version? 😉

    Greetings

    Marian

Viewing 15 posts - 1 through 15 (of 22 total)

This topic contains 22 replies, has 8 voices, and was last updated by  julinc 6 years, 6 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum