Viewing 15 posts - 1 through 15 (of 59 total)
  • Author
    Posts
  • lo30sopa6 Developer
    #166929

    I just found out that the current T3 templates only allow 1 main menu.

    Normally this shouldn’t be such a problem, unless you are using the new built in multi-language option in Joomla 1.7.

    The problem is this:

    I created 2 language specific (main) menus but you can only assign one of those menus in the template to use the mega-menu. This results in the disappearing of the menu when I witch to another language :((

    Anyone got a workaround for this?

    Best,
    Steve

    tolrem Friend
    #404218

    I have exactly the same issue here.

    Like you, i created twice the same template, one for main language, one for secondary language.

    They work fine, but mainnav menu disappears when switching languages.

    One workaround is to enable development mode in both templates.

    Disabling it enables cache, and the first language to be displayed is stored in cache, so it doesn’t let free room for the other language.

    chavan Friend
    #404370

    Hi Steve & tolrem

    You can solve this problem as following step (I suppose your site has 2 languages – English and French)
    – Access template manager
    – Create a profile name: default-fr
    – Select menu English in default profile, and menu French in default-fr profile
    – In Page Assignments, assign all English menu for default profile & all French menu for default-fr profile.

    Save & surf your website.

    tolrem Friend
    #404376

    Thank you, I will try this 😉

    tolrem Friend
    #404505

    It’s working, but partially.

    Menus appear properly in each language, but the trouble is with unassigned components items (like create an account, or everything that has a not a menu item associated), only one language car be setup for them.

    chavan Friend
    #404577

    Hi tolrem

    I saw this problem. There is another solution can solved it. You could following above step:
    1. Upgrade T3 plugin to latest version.
    2. Copy folder templates/ja_t3_blank to other place outside folder of website.
    3. Rename ja_t3_blank to ja_t3_blank_fr
    4. Open file templateDetails.xml in folder ja_t3_blank_fr. Rename ja_t3_blank in tag name to ja_t3_blank_fr
    5. Zip folder ja_t3_blank_fr and install it into your site.
    6. Access template manager and assign French for ja_t3_blank_fr and change suitable menu.

    paul.necsoiu Friend
    #404688

    I have this issue too

    In the http://docs.joomla.org/Language_Switcher_Tutorial_for_Joomla_1.6
    you will find

    As the Language Switcher Module is set to redirect to another Content Language Home Page, one
    Default Home page menu item has to be defined for each language in a different menu, displayed by
    a different menu module.
    and
    WARNING! Some templates available on the Net are not totally 1.6 compatible. They do not
    let create new styles and force to use a unique Default Home page.

    So I think the problem must be solved by the Joomlart team by upgrading the JA T3 Framework to work with all features of Joomla 1.7.

    I think one possibility would be to add multiple Menu Types (one for each language) in JA T3 Menu Settings.

    dade88 Friend
    #404812

    Nice Do Ha, I’m also in production of a site and was arguing on how to solve this issue (I plan to add even more languages so imagine the size of the problem :-[).

    I would like to know if JA is going to ‘fix’ this issue soon, or is not a milestone for the staff?

    EDIT: Sorry but your both methods are not working for me… in both cases it changes to the menu I select. For example, when I make default-es & default-en (or ja_t3_blank_es & ja_t3_blank_en for the second try), when I switch default-es main menu to ‘esmenu’ (my spanish menu), it also sets the same main menu for the other profile, template. I even tried to duplicate templates from Template Manager (guess it is the same than your second proposal) but the result is still the same. It has to be assigned to all pages to assure all pages are correctly showed, any other workaround?

    Thanks for your time,
    Davide

    chavan Friend
    #404926

    Hi dade88

    I tested my method and it worked normally. It’s similar you use 2 different templates. And each template is assigned to a language.

    dade88 Friend
    #404975

    I get confused with Purity II 😛

    Anyway, I solved it by manually editing the DB trough phpmyadmin and now is working 🙂

    Hope in future T3 Framework will have this feature, as it just about the ability to set a menu for each profile (or just not let it override all the profiles).

    lo30sopa6 Developer
    #405497

    <em>@Do Ha 257375 wrote:</em><blockquote>Hi Steve & tolrem

    You can solve this problem as following step (I suppose your site has 2 languages – English and French)
    – Access template manager
    – Create a profile name: default-fr
    – Select menu English in default profile, and menu French in default-fr profile
    – In Page Assignments, assign all English menu for default profile & all French menu for default-fr profile.

    Save & surf your website.</blockquote>

    Thanks for the advise. I’ll try it and report back.

    kanum Friend
    #409774

    <em>@Do Ha 257375 wrote:</em><blockquote>

    You can solve this problem as following step (I suppose your site has 2 languages – English and French)
    – Access template manager
    – Create a profile name: default-fr
    – Select menu English in default profile, and menu French in default-fr profile
    – In Page Assignments, assign all English menu for default profile & all French menu for default-fr profile.

    Save & surf your website.</blockquote>

    But I only get on page the Home (default Home menu). Wich if I use multi language need to be assign to “All”. I mean, If I have english menu and the french menu Home (default) Appear allways 🙁

    How Can I fix it?

    Thanks

    allbuster Developer
    #410843

    Hi,

    We have JA Rave and Joomla 1.7
    French and English run correctly in menu in Left-position. But not in Top Menu.
    We have try with your procedure (change tag name in xml in a copy of this template) but unlucky.

    Have you an other track? A patch in future?

    Thanks

    barbara779 Friend
    #415662

    <em>@Do Ha 257674 wrote:</em><blockquote>Hi tolrem

    I saw this problem. There is another solution can solved it. You could following above step:
    1. Upgrade T3 plugin to latest version.
    2. Copy folder templates/ja_t3_blank to other place outside folder of website.
    3. Rename ja_t3_blank to ja_t3_blank_fr
    4. Open file templateDetails.xml in folder ja_t3_blank_fr. Rename ja_t3_blank in tag name to ja_t3_blank_fr
    5. Zip folder ja_t3_blank_fr and install it into your site.
    6. Access template manager and assign French for ja_t3_blank_fr and change suitable menu.</blockquote>

    Thank you! I had the same issue and it works out fine now. 🙂

    allbuster Developer
    #415665

    <em>@barbara779 271421 wrote:</em><blockquote>Thank you! I had the same issue and it works out fine now. :)</blockquote>

    Hi,
    We have no solution for this problem. Idem with JA PurtyII (test yesterday).
    – Menu on the Top : KO
    – Menu on the left : OK

    But that run very good with the Template Beez in Joomla.

Viewing 15 posts - 1 through 15 (of 59 total)

This topic contains 59 replies, has 33 voices, and was last updated by  marinaw 7 years, 6 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum