Viewing 12 posts - 16 through 27 (of 27 total)
  • Author
    Posts
  • The Captain Moderator
    #1008394

    Hi John,

    To solve this problem, you can try solution below.

    Fist, try to install the Multi Capcha Engine plugin for JA Quick Contact module again.

    After finish install, go to the Plugins Manage in the backend, find and disable the Captcha- reCaptcha plugin. Please make sure that you enable the Content – CAPTCHA plugin.

    Take a backup of your site.

    In the path : [YOUR-SITE]/modules/mod_jaquickcontact/mod_jaquickcontact.php, find the code:

    $captcha = JPluginHelper::importPlugin('captcha', 'recaptcha');

    and replace them by the code :

    $captcha = JPluginHelper::importPlugin('content', 'captcha');
    if (!$captcha) {
        $captcha = JPluginHelper::importPlugin('captcha', 'recaptcha');
    }

    Then, in the path : [YOUR-SITE]/modules/mod_jaquickcontact/tmpl/ajax_layout.php, find the code :

    $cp_plugin = JPluginHelper::getPlugin('captcha', 'recaptcha');

    and replace them by the code:

    $cp_plugin = JPluginHelper::getPlugin('content', 'captcha');
                    if (!$cp_plugin) {
                        $cp_plugin = JPluginHelper::getPlugin('captcha', 'recaptcha');
                    }

    You can give it a try and inform me the result.

    Regards

    john patrikiadis Friend
    #1008553
    This reply has been marked as private.
    john patrikiadis Friend
    #1008741

    Although I have received emails from the site, i suppose, i cannot send when i try it myself. Can you please tell me what is going on?

    The Captain Moderator
    #1008759

    Hi John,

    I fixed this problem on your site. I changed some codes on two files like the attachment :
    +/ [YOUR-SITE]/modules/mod_jaquickcontact/mod_jaquickcontact.php
    +/ [YOUR-SITE]/modules/mod_jaquickcontact/tmpl/default.php

    Kindly take a look.

    Regards


    john patrikiadis Friend
    #1008830

    When i try to use the form I still get the same error. Wrong captcha. What have you done? What should I do ?

    The Captain Moderator
    #1008934

    Hi,

    Could you try to clear browser’s cache & cookies then try again?

    I also tried to use the form on your site and the module is working properly now, without seeing the wrong captcha error message. See attached screenshot:


    1. screenshot-arion.gr-2017-02-08-09-43-09
    john patrikiadis Friend
    #1008963

    i have checked. It is ok. Thank you very much

    john patrikiadis Friend
    #1008967

    can i define to which mail I would like to receive the message?

    Saguaros Moderator
    #1008983

    Hi John,

    By default, the recipient email will be admin email which is set via Global Configuration. You can also add recipient emails in backend settings of this JA Quickcontact module.

    Regards

    p119foundation Friend
    #1009314

    Hello, all,

    Just want to chime in and mention that I had the same situation (ja_quickcontact installed with the ja_multiple_captcha_engine) and was getting the same error. I tried several things and think I may have found the solution in one of them:

    My site is an older one that had ReCaptcha keys from before the time Google owned it. When I went to https://www.google.com/recaptcha/admin, I realized my domain was not listed there so I added it and got new captcha keys.

    That still didn’t seem to fix the problem so I explicitly added my non-www domains (including test.mydomain.com).

    That still didn’t seem to fix the problem so I checked my captcha plugins and realized I still had the Joomla-default "Captcha – ReCaptcha " plugin enabled. I disabled that and everything now works just fine!

    I hope this helps! 🙂

    p119foundation Friend
    #1009344

    Disregard.

    I just realized that I was using a cached version of the Contact Us page (that showed the CAPTCHA) but when I disabled the default ReCaptcha plugin, it simply bypassed the need for validation.

    The problem still remains. 🙁

    p119foundation Friend
    #1009347

    Updated the site using the two files in the zip file (above). Still no luck.
    Then I realized that those files were overridden in the template (ja_onepage!) and when I replaced the overrides with the same update everything worked like a champ. Merging the styles of ja_onepage with the technical function of the zip files was a bit tricky but all is working now.

Viewing 12 posts - 16 through 27 (of 27 total)

This topic contains 27 replies, has 4 voices, and was last updated by  p119foundation 2 years ago.

The topic ‘wrong captca or wrong email’ is closed to new replies.