Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • lunarview22 Friend
    #206432

    Hello,

    I’ve built quite a few joomla/Joomlart sites, but one of them is doing unexpected things when i try to search for it on google. The site is lasersafetyaustralia.com.au.

    The site definitely shows up in Google search results, if I pick, for example, a text-string from somewhere in the site, and google it.

    but if I search on typical generic terms for the site, it doesn’t seem to have any traction within google. I’m stumped as to why this would be, as I have done all the usual correct things, and they normally work well enough with my other sites. But on this one something seems “not quite right”.

    The main thing that is telling me something is weird, is that if I do a search, say for the string “laser safety australia” (without the quotation marks) in google.com.au, I would expect to see some good results. instead, it only brings up one page from my site, and here is the weird thing: it is not even a real page. The address of the page which is brings up is
    http://lasersafetyaustralia.com.au/index.php/home/about-laser-safety-australia/9-information

    As I say, this does not correspond to any page that I have built. when I click on it, it brings up a page which has a list of four other pages on my site.

    Why? How? What the?

    Can anyone make any suggestions as to why this page is being retrieved by google? Can anyone also make suggestions as to why no other pages seem to be picked up when I do general keyword searches like this? Any clues will be very welcome. Thanks.

    cheers

    Ninja Lead Moderator
    #571057

    I guess the problem on your site to regard Rewrite module from your hosting did not enable from php.ini file, you can go to Global Configuration backend site and check it again


    1. Screen-Shot-2015-05-19-at-15.52.19
    Ninja Lead Moderator
    #736105

    I guess the problem on your site to regard Rewrite module from your hosting did not enable from php.ini file, you can go to Global Configuration backend site and check it again

    lunarview22 Friend
    #572301

    thanks for your reply

    are you saying i should just turn off URL rewriting?

    ok, but why would this bring up a page on google that does not exist on my site?

    thanks

    lunarview22 Friend
    #737338

    thanks for your reply

    are you saying i should just turn off URL rewriting?

    ok, but why would this bring up a page on google that does not exist on my site?

    thanks

    Ninja Lead Moderator
    #572756

    <em>@lunarview22 475652 wrote:</em><blockquote>thanks for your reply

    are you saying i should just turn off URL rewriting?

    ok, but why would this bring up a page on google that does not exist on my site?

    thanks</blockquote>

    I checked and your site is working fine with turn off URL rewriting option under global configuration, if you want to have URL rewriting then you need to ask your hosting provider to enable mod_rewrite in php.ini file

Viewing 6 posts - 1 through 6 (of 6 total)

This topic contains 6 replies, has 2 voices, and was last updated by  lunarview22 3 years, 11 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum