Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • user11224767 Friend
    #166445

    Hello!
    The Quickstart doesn’t work with MYSQL 5.5!
    Can you update please!>:(

    Phill Moderator
    #401808

    What errors are you getting?

    MySQL 5.5, which version exactly? there are 2 further digits that may help resolve your problem.

    user11224767 Friend
    #401815

    Hi!
    The error is
    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘TYPE=MyISAM CHARACTER SET `utf8`’ at line 29 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default ‘0’, `type` varchar(30) NOT NULL default ‘banner’, `name` varchar(255) NOT NULL default ”, `alias` varchar(255) NOT NULL default ”, `imptotal` int(11) NOT NULL default ‘0’, `impmade` int(11) NOT NULL default ‘0’, `clicks` int(11) NOT NULL default ‘0’, `imageurl` varchar(100) NOT NULL default ”, `clickurl` varchar(200) NOT NULL default ”, `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default ‘0’, `checked_out` tinyint(1) NOT NULL default ‘0’, `checked_out_time` datetime NOT NULL default ‘0000-00-00 00:00:00’, `editor` varchar(50) default NULL, `custombannercode` text, `catid` INTEGER UNSIGNED NOT NULL DEFAULT 0, `description` TEXT NOT NULL DEFAULT ”, `sticky` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0, `ordering` INTEGER NOT NULL DEFAULT 0, `publish_up` datetime NOT NULL default ‘0000-00-00 00:00:00’, `publish_down` datetime NOT NULL default ‘0000-00-00 00:00:00’, `tags` TEXT NOT NULL DEFAULT ”, `params` TEXT NOT NULL DEFAULT ”, PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`), INDEX `idx_banner_catid`(`catid`) ) TYPE=MyISAM CHARACTER SET `utf8`

    Its Version:
    Server Version: 5.5.12
    Protokoll-Version: 10

    Phill Moderator
    #401834

    Please open the file installation/sql/mysql/joomla.sql using a normal text editor such as notepad do a find-replace.

    Find all occurrences of the string – TYPE=MYISAM

    and replace them all with – ENGINE=MYISAM

    Not many people are using your version of MySQL yet. It is mainly people using setups on their local machines. Fortunately on those you can simply use an earlier version of MySQL.

    user11224767 Friend
    #401843

    Problem solved!
    My provider converted the database to 5.1!
    Thanks!:)

    Phill Moderator
    #401846

    Best option IMHO. There are many Joomla plugins not working with 5.5 yet. Good luck with your site.

    I have raised the question to get all of the JA templates files updated but there are a lot of them so it may take a little while.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic contains 6 replies, has 2 voices, and was last updated by  Phill 12 years, 11 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum