Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • linebille Friend
    #128225

    Hi,

    I have a problem with the JAnewsflash module – the newsflash isn’t rotating. Only when the whole page is refreshed.

    In IE7 I get an errormessage in the browser that says “access denied”.

    FF says “Permission denied to call method XMLHttpRequest open”

    What is wrong here?

    Sherlock Friend
    #247899

    Hi linebille !
    Please send super admin account via pm , i will check it for you !

    tweek82 Friend
    #247938

    If you know the solution, please let me know, I’ve a same thread about this in this same forum.

    Thanks

    Menalto Friend
    #247952

    Im not sure if this will help or not,but check what you have in your configuration.php for your live site.
    If its yourdomain.com or http://www.yourdomain.com.
    Remember that this is two different domains.
    and this is not a bug in the module, this is a security for all browsers.

    Check it by enter yourdoman.com if it works
    then go to it by http://www.yourdomain.com.

    To make sure that your sites visitors dont get problems you can add this to the htaccess file:

    Options +FollowSymLinks
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^yourdomain.com [NC]
    RewriteRule ^(.*)$ http://www.yourdomain.com/$1 [L,R=301]

    Remember to replace yourdomain with your own domain
    And change in the configuration.php to http://www.yourdomain.com too

    Sherlock Friend
    #247988

    Yes , I think that this is problem ,
    tweek82 ! please try to edit as Menalto say!

    linebille Friend
    #248039

    Thanks, this works 🙂

    tweek82 Friend
    #248049

    Well, my live_site setting is correct:
    var $live_site = ‘http://www.stevin.eu’;

    If I navigate to http://www.stevin.eu the ja_newsflash appears correct.
    If I navigate to http://stevin.eu (without the ‘www’), ja_newsflash crashes.

    How can I force the site to allways add the www. prefix? I want this site to be able to be accessed by either stevin.eu as http://www.stevin.eu.

    Thanks in advance

    ps.
    I tried the htaccess. solution:

    Options +FollowSymLinks
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^stevin.eu [NC]
    RewriteRule ^(.*)$ http://stevin.eu/$1 [L,R=301]

    linebille Friend
    #248051

    Just put the rewrite rule from menalto in to your .htaccess and it should work 🙂

    tweek82 Friend
    #248058

    It worked!!! Many thanks to all.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic contains 9 replies, has 4 voices, and was last updated by  tweek82 16 years, 1 month ago.

We moved to new unified forum. Please post all new support queries in our New Forum