Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • dave_3d Developer
    #1001395

    Copied from my post in the general section ( https://www.joomlart.com/forums/topic/ja-t3-bootstrap-template-and-k2-submenu-option/ ). Probably better in this forum section.

    Using default JA T3 Blank Bootstrap template from here : http://www.t3-framework.org/ latest version (2.6.2)

    I am encountering a problem with trying to display the Megamenu with menu items that are K2 listings. I want to switch off submenus, but using K2 the megamenu settings ignore this setting.

    In the Megamenu setup page, I have the option to switch on/off submenu for any menu item. With this set to off for my K2 menu item (which has sub menu items) it STILL displays the sub items. I have other links to standard category views (not K2) with sub menus and tehy work correctly if I select OFF for submenu.

    Is there any way to get my K2 menu items to respect the submenu off setting ?

    I have JA Developer Membership.

    Thanks,

    Dave

    Attached images :

    Megamenu_submenu_off_K2.jpg

    Shows settings set to OFF for submenu in Megamenu setup. Menu selected is a K2 display categories menu item.

    Megamenu_submenu_off_standard.jpg

    Shows settings set to OFF for submenu in Megamenu setup. Menu selected is a standard display categories menu item.

    Megamenu_bug_shows_submenu.jpg

    Shows that the standard menu item to dispaly categories does not display submenus – as expected. BUT, the link to the K2 Categories does display submenu – even when switched OFF.


    1. Megamenu_submenu_off_standard-1
    2. Megamenu_submenu_off_K2-1
    3. Megamenu_bug_shows_submenu-1
    pavit Moderator
    #1001408

    Hello

    Could you please share as Private Reply a temp super user account to your backend ?

    I will have a look at it

    dave_3d Developer
    #1001418
    This reply has been marked as private.
    pavit Moderator
    #1001511

    Hello

    When you set permissions for menu items in Megamenu configuration it is a good praxis to verify them for all permissions groups.
    In your case you leaved submenu ON for your GUEST group –
    I removed it now and as you can see it works fine.

    Regards


    1. Screenshot-at-gen-11-07-40-47
    dave_3d Developer
    #1001638

    Thank-you Pavit.

    My mistake. I hadn’t seen that I changed away from guest. I’ll take note of that in the future.

    Thanks for the speedy reply and solution.

    Dave

Viewing 5 posts - 1 through 5 (of 5 total)

This topic contains 4 replies, has 2 voices, and was last updated by  dave_3d 8 months, 2 weeks ago.

You must be logged in to reply to this topic.