Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • nunofirmino Friend
    #132695

    Greetings,

    I’m having a problem with the installation of JA Olyra in Joomla 1.5.6

    I’m getting the following error on the public page: “Warning: Invalid argument supplied for foreach() in /home/username/public_html/templates/jaolyra/ja_menus/Base.class.php on line 142”

    Don’t know what’s going on so need some help.

    Sorry for the english… :-[

    skoobi Friend
    #267752

    ye im getting the same problem… ive checked the forum and theres no positive solution.

    skoobi Friend
    #267819

    Hi does anyone have an answer to this as its a bit of a pain…… Ive tried this template on a few different servers to see if it was my site but it does it on them too. I thaught it could be the menu but im still having the same problems..

    Help!!!!!!

    nunofirmino Friend
    #267822

    The problem is the menu, that’s for sure.

    I had 2 menus and I had 2 error messages for each menu. After unpubilishing one of the menu’s (main menu at the top) I’m having only one error message.

    Isn’t there any solution for this template?

    skoobi Friend
    #267902

    Right i found the solution…

    Try turning the ‘Template Icon menu’ param off in the template settings first.

    see what error you get. if you have modified the template so the icons menu is user3 then you may want to try this code…..

    In the ja_orlyra/index.php around line 108

    Change

    <?php if ($tmpTools->getParam(JA_TOOL_ICONMENU)) { ?>
    <div id="ja-topnav"><div class="w1"><div class="w2"><div class="w3 clearfix">
    <?php
    //include(dirname(__FILE__).DS."ja_iconmenu.php");
    $jamenuicon->genMenu(0,0,0);
    ?>
    </div></div></div></div>
    <?php } ?>

    to this

    <div id="ja-topnav"><div class="w1"><div class="w2"><div class="w3 clearfix">

    <jdoc:include type="modules" name="user3" style="xhtml" />

    </div></div></div></div>

    REMEMBER TO BACK UP YOUR FILES…..

    nunofirmino Friend
    #267951

    Thanks for the repply

    I haven’t changed anything on the template yet… Just installed and it gave me that error.

    When i turn off the menu’s icons it shows me this error with a blank page:
    Fatal error: Class ‘JA_’ not found in /home/username/public_html/templates/jaolyra/ja_vars.php on line 73

    I’ve changed that piece of code you tould me but it get’s me the same error line before. I’ve put it back as it was.

    Any more help would be apreciated:confused:

    skoobi Friend
    #267957

    Ye sorry in the ja_vars i changed the code too.

    It Was ::


    }
    $menuiconclass="JA_$menu_icon";
    $jamenuicon=new $menuiconclass ($japarams_2);
    //end

    Now it is::

    }
    $menuiconclass="JA_$menu_icon";
    //end

    Just remembered about that. If you change the index aswel so its user 3 instead of ‘getmenu’ and switch off the template icon menu in the template params you should be ok.

    Back up your files first though…… It worked for me im not sure if it will work for anyone else.

    Its probably not the best way of doing it but im on a tight schedule….. and needed that error gone..

    Hope this works for you !!!!!!:)

    nunofirmino Friend
    #268025

    Thanks skoobi, it worked just fine 😉

    I just have one more question. I want to publish a icon menu in ‘user 3’ diferent from the top menu. I’ve published a new menu under the ‘user 3’ position and uploaded a test icon for that menu.

    How do I configure module so that it shows the icon on top of the menu text link?

    Just managed to put it on the right or on the left of the menu link.

    nunofirmino Friend
    #268616

    Can anyone help me with this?

    This is the look of the new module position:

    2705

    I’ve set the the module menu to be “legacy flat list” and the menu’s class suffix to “-nav” but the icon menu shows me the way it is in the picture.

    How can I set it to be like in JA Olyra demo?


    1. new-module
    skoobi Friend
    #268634

    Try the ‘-topnav’ css. it might work. At least i think its that

    nunofirmino Friend
    #268785

    <em>@skoobi 77546 wrote:</em><blockquote>Try the ‘-topnav’ css. it might work. At least i think its that</blockquote>

    No, didn’t make any change in the menu… I must be doing anything wrong. :confused:

    nunofirmino Friend
    #269836

    Ok, just upgraded to joomla 1.5.7 an reinstalled template.

    Everything working ok now. Still don’t know what was the problem but maybe a corrupt installation in the first try.

    samtzu Friend
    #271581

    I did all of the above changes to index.php and ja_vars and still… getting error in /templates/jaolyra/ja_menus/Base.class.php on line 152.
    Joomla 1.5.7

    Sam

    samtzu Friend
    #271583

    Solved it.
    If you change the names of the menu “type” in Joomlas “Menu Manager” (nothing to do with the template) then this is what you get.

    So the “problem” with the template is that it only works with the “default” menu names.

    Sam

Viewing 14 posts - 1 through 14 (of 14 total)

This topic contains 14 replies, has 3 voices, and was last updated by  samtzu 15 years, 10 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum