Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • esedic Friend
    #159461

    Hi!

    I would like to know, how could I hide main content block only on frontpage?
    Right now if I set Hide Main content block to Yes in Global settings this block is hidden on all the pages.

    Thanks

    aman204 Friend
    #374339

    You can create a new profile in template parameters and then, set override for content block to hide for specific profile

    Then, You can assign this profile for homepage

    slewis1972 Friend
    #393186

    Hi

    Did you did, this and if so how as want to do the same.

    Thanks

    pallavi_t Friend
    #393508

    Hi,
    Please try following steps:
    1.Go to joomla backend/Extensions menu/Template Manager/your Template
    2.Select profiles tab,create new profile.
    3.Select your new profile,check the checkbox at the right side of the ‘Hide main content block’ then select ‘yes’ from its combobox
    6.select Global tab
    7.In ‘Profile Override Setting’,select all home menu items and click on select link
    8.note that for all pages your default profile is selected and for home page new profile is selected
    9.Apply the changes and ckeck on the front page

    duckpond Friend
    #397705

    <em>@pallavi_t 243419 wrote:</em><blockquote>Hi,
    Please try following steps:
    1.Go to joomla backend/Extensions menu/Template Manager/your Template
    2.Select profiles tab,create new profile.
    3.Select your new profile,check the checkbox at the right side of the ‘Hide main content block’ then select ‘yes’ from its combobox
    6.select Global tab
    7.In ‘Profile Override Setting’,select all home menu items and click on select link
    8.note that for all pages your default profile is selected and for home page new profile is selected
    9.Apply the changes and ckeck on the front page</blockquote>

    Very cool! Thanks!

    Now I am able to vacant the main content area, how do I publish modules in this area then?

    chavan Friend
    #397807

    You should use some extensions to load module in an article (don’t need to hide content).

    midsomer Friend
    #399931

    If using JA-Social J1.6 I discovered that you set up the profile overide in the Page Assignments on the lefthand side in Template Manager.

    In Pages ‘click to add’ gives you a list to pick from, choose Main Menu -> home (mine showed an id number 435 when picked)
    In Profiles ‘click to add’ gives you a list of profiles, hopefully including yours, to pick from.

    A minor point. I think the no-entry icon for remove an override should be changed to an X.

    nebfx Friend
    #549119

    I’m facing same problems with the main content block, and those above answers are helpful, many thanks. However, I’m getting another problems too, I did make another profile as above instructrion to hide main content block but not only in my front page but also in another menu pages, problem is, when I hid the main block, the single article pages are also hidden.
    Is there anyways to solve that issue?

    Saguaros Moderator
    #549236

    Hi nebfx,

    Seem that you also assign that profile (which hide main content) to other menu item which that article belongs to. Hence, it also hides the main content block in that article page. Please check this profile again

    JAT3 v2 has option so that you can create different profiles and assign to different pages so you can create another profile and assign to menu item of page you want to hide main content ONLY.

    Remember to clean JAT3 cache once done.

    Best

Viewing 9 posts - 1 through 9 (of 9 total)

This topic contains 9 replies, has 9 voices, and was last updated by  Saguaros 4 years, 8 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum