Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • fortza Friend
    #145924

    Hi.

    I have a LOT of problems installing this demo componet…….I´m getting this message, when trying to install the “com_ :

    Warning: realpath() [function.realpath]: open_basedir restriction in effect. File(/usr/lib64/php/modules) is not within the allowed path(s): (/var/www/web155) in /var/www/web155/web/components/com_jajobboard/helper/jafunctions.class.php on line 2

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/var/www/ioncube/ioncube_loader_lin_5.2.so) is not within the allowed path(s): (/var/www/web155) in /var/www/web155/web/components/com_jajobboard/helper/jafunctions.class.php on line 2

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/var/ioncube/ioncube_loader_lin_5.2.so) is not within the allowed path(s): (/var/www/web155) in /var/www/web155/web/components/com_jajobboard/helper/jafunctions.class.php on line 2
    Site error: the file /var/www/web155/web/components/com_jajobboard/helper/jafunctions.class.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.

    Any help on this issue ?

    Best, Fortza

    Anonymous Moderator
    #323194

    Hi fortza

    I think the version of ionCube loader is not version 5.2. Maybe it is the old version.

    Please kindly ugrade it to version 5.2 and install this component again.

    Also, you can submit a ticket, send us your live url, admin account, ftp account so that we have a closer look on the issue.

    fortza Friend
    #323197

    Hi.

    Thanks for your answer – but where and how do i upgrade….where do i find “ionCube” ver. 5.2

    Best, Fortza

    Anonymous Moderator
    #323199

    Hi fortza

    Please read our wiki: http://wiki.joomlart.com/wiki/JA_Job_Board/Installation_Guides with step #2

    John Wesley Brett Moderator
    #323334

    Hi…Having the same issue and I do have ionCube 5.2 installed (see attachment)

    Installed ionCube, uploaded the new 1.3 version – no problems.
    BUT…when selecting COMPONENTS > JA JOBBOARD in the Admin area I get:

    Site error: the file /…/components/com_jajobboard/helper/jafunctions.class.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.

    Everything works…I can change templates, modules, add content, everything…EXCEPT being the JA JobBoard component on the back end…that’s where I get the error.

    Thoughts?
    Thanks.
    John.

    Anonymous Moderator
    #323950

    Hi jbrett

    I am afraid that you are install the latest version of ion cube. In /info.php file, i could see that you installed it but in administrator, go to Help -> System info -> PHP information tab, you will see that this loader did not show.

    Please kindly contact with your server manager to fix it.

    John Wesley Brett Moderator
    #323991

    Found my error. I’m running the JA JobBoard instance in a subdirectory of the main domain:

    i.e.: http://www.example.com/jaJobBoard

    So…when installing ionCube the ionCube folder, and the “.so” files inside it, can be located in the subdirectory…as long as the path is correct in the php5.ini file.

    HOWEVER: the php5.ini file MUST be placed in the ROOT DIRECTORY…NOT the Sub-Directory and this was my problem.

    And for those trying to install this on a GODADDY or 1&1 WebHosting – here is a great walkthrough for you:
    http://geodesicsolutions.com/latest-software-news-blog/197-important-is-your-host-upgrading-php.html

    Have fun.
    John.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic contains 7 replies, has 3 voices, and was last updated by  John Wesley Brett 14 years, 7 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum