Bug in JA Extensions Manager - JoomlArt
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • coalition Friend
    #175612

    I continue to get this error whenever I run Joomla’s updater from the joomla 2.5.3 admin panel.

    Walt

    Manos Moderator
    #446801

    Hi,

    This is not actually a bug, but as you already know JA software is commercial so i guess it’s a permission issue, that’s why we suggest using JA Extension Manager to update JA products.

    The strange thing is that i haven’t seen this error on any J2.5.x site, unless you have an old version of JA Extension Manager.

    Regards

    coalition Friend
    #446865

    No, this is definitely a bug. Look at the URl in the post. There is a space after “xml” and before the “/.” JA Extension manager seems to work alright, but using the core joomla 2.5.3 updater produces the error below. Even though JA products are commercial, these types of errors should not be occurring. I am using the latest JA Extension Manager component.

    Manos Moderator
    #447890

    Hi,

    I have informed our dev’s to take a look on than and we will reply as soon as possible.
    The strange thing is that no matter what i have tried i wasn’t able to reproduce that issue, even though i was getting this when Joomla 2.5.0 was out.

    Thanh Nguyen Viet Developer
    #447949

    Dear Colition,

    Please open xml manifest file of our extensions, then find the code snippet

    <updateservers>
    <server type=”collection”>http://update.joomlart.com/service/tracking/list.xml</server&gt;
    </updateservers>
    Please remove all white spaces before and after the link ‘http://update.joomlart.com/service/tracking/list.xml’ if any.
    E.g:
    Before
    <updateservers>
    <server type=”collection”>
    http://update.joomlart.com/service/tracking/list.xml
    </server>
    </updateservers>

    After:
    <updateservers>
    <server type=”collection”>http://update.joomlart.com/service/tracking/list.xml</server&gt;
    </updateservers>

    imami Friend
    #449970

    it’s better to edit :
    [joomla directory] librariesjoomlaupdateradapterscollection.php

    on line : 214
    change this code :
    [PHP]$url = $options[‘location’];[/PHP]

    to :
    [PHP]$url = trim($options[‘location’]);[/PHP]

    and the problem will be solved for ever ! 😉

    Thanh Nguyen Viet Developer
    #450026

    Yes, you’re right.

    But the better way is that you should raise an issue on official Joomla Issue Tracker system rather than hacking core code 😉

Viewing 7 posts - 1 through 7 (of 7 total)

This topic contains 7 replies, has 4 voices, and was last updated by  Thanh Nguyen Viet 4 years, 3 months ago.

You must be logged in to reply to this topic.