Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • degarrin Friend
    #189558

    Hello, we just installed JA Voice this evening and are going through the configuration settings, no problems for the most part. However, when attempting to edit the Voice Types (as the Super Admin), I receive the following error message:

    Fatal error: Class ‘JHtmlList’ not found in ……../components/com_javoice/models/voicetypes.php on line 163

    This occurs no matter which Voice Type I try to edit; these are just the default types that came with the extension. We are running Joomla 2.5.14 and JA Voice 1.1.0.

    Any help is greatly appreciated.

    Thank You!
    Angela

    degarrin Friend
    #501681

    This was submitted as a support ticket. Sorry for the mix up.

    Corvin & Angela

    MoonSailor Friend
    #501702

    Hi Corvin Adkins,

    It’s fixed, pls take a look at it.

    In file “components/com_javoice/models/voicetypes.php” I changed :


    function getOrdering($item) {
    $neworder = 0;
    $query = 'SELECT ordering AS value, title AS text' . ' FROM #__jav_voice_types' . ' ORDER BY ordering';

    if (is_object($item))
    {
    $item = $item->ordering;
    }

    if (isset($item->id))
    {
    $neworder = 0;
    }
    else
    {
    if ($neworder)
    {
    $neworder = 1;
    }
    else
    {
    $neworder = -1;
    }
    }
    return JHtmlList::ordering('ordering', $query, '', $item, $neworder);

    //return JHTML::_ ( 'list.specificordering', $item, $item->id, $query );
    }

    to :

    $query = 'SELECT ordering AS value, title AS text' . ' FROM #__jav_voice_types' . ' ORDER BY ordering';
    $neworder = 0;
    if(version_compare(JVERSION, '3.0', 'ge')){

    if (is_object($item))
    {
    $item = $item->ordering;
    }

    if (isset($item->id))
    {
    $neworder = 0;
    }
    else
    {
    if ($neworder)
    {
    $neworder = 1;
    }
    else
    {
    $neworder = -1;
    }
    }
    return JHtmlList::ordering('ordering', $query, '', $item, $neworder);
    }else{
    return JHTML::_ ( 'list.specificordering', $item, $item->id, $query );
    }

    Regards.

    operaghost Friend
    #502910

    <em>@MoonSailor 384163 wrote:</em><blockquote>Hi Corvin Adkins,

    It’s fixed, pls take a look at it.

    In file “components/com_javoice/models/voicetypes.php” I changed :


    function getOrdering($item) {
    $neworder = 0;
    $query = 'SELECT ordering AS value, title AS text' . ' FROM #__jav_voice_types' . ' ORDER BY ordering';

    if (is_object($item))
    {
    $item = $item->ordering;
    }

    if (isset($item->id))
    {
    $neworder = 0;
    }
    else
    {
    if ($neworder)
    {
    $neworder = 1;
    }
    else
    {
    $neworder = -1;
    }
    }
    return JHtmlList::ordering('ordering', $query, '', $item, $neworder);

    //return JHTML::_ ( 'list.specificordering', $item, $item->id, $query );
    }

    to :

    $query = 'SELECT ordering AS value, title AS text' . ' FROM #__jav_voice_types' . ' ORDER BY ordering';
    $neworder = 0;
    if(version_compare(JVERSION, '3.0', 'ge')){

    if (is_object($item))
    {
    $item = $item->ordering;
    }

    if (isset($item->id))
    {
    $neworder = 0;
    }
    else
    {
    if ($neworder)
    {
    $neworder = 1;
    }
    else
    {
    $neworder = -1;
    }
    }
    return JHtmlList::ordering('ordering', $query, '', $item, $neworder);
    }else{
    return JHTML::_ ( 'list.specificordering', $item, $item->id, $query );
    }

    Regards.</blockquote>

    Followed this change and now get a blank page with error: Parse error: syntax error, unexpected T_VARIABLE, expecting T_FUNCTION in …/com_javoice/models/voicetypes.php on line 139

    MoonSailor Friend
    #503524

    Hi operaghost,

    If possible, you can send PM to me admin and ftp login info of your site. I will check it for you.

    Regards

Viewing 5 posts - 1 through 5 (of 5 total)

This topic contains 5 replies, has 3 voices, and was last updated by  MoonSailor 7 years, 1 month ago.

We moved to new unified forum. Please post all new support queries in our New Forum