Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • rocher Friend
    #1095504

    Hi,

    I’ve noticed there’s a lot of wasted white space at the bottom of the Featured Articles (homepage) and Category Blogs (menu items) on my website: https://www.tallandtrue.com.au

    When I use Web Inspector (on Safari) I can see a CSS setting for min-height of 646px on the Home page (see attached screenshot). If I deselect this setting in Web Inspector, then the white space is removed.

    For the Fiction menu item (https://www.tallandtrue.com.au/fiction/), the min-height setting is 842px. Again, if I deselect this the excess white space is removed.

    I can’t find a setting for this in the CSS files, so I assume it’s dynamically worked out by the display routines. Could you please advise how this can be resolved?

    I updated Joomla and the template and plugins to the latest version today and the problem still exists.

    Please note, my template uses a custom PHP you provided where blog.php calls blog_leading.php or blog_item.php to display either the full image or intro image for the featured and category blog articles.

    Regards, Robertf

    • This topic was modified 9 months, 1 week ago by  rocher.

    1. tallandtrue-featuredarticles-homepage
    rocher Friend
    #1095506
    This reply has been marked as private.
    rocher Friend
    #1095691

    Hi,

    I also have a testing/staging environment for my website: http://staging.robertfairhead.com

    On this website, I don’t have any whitespace problems on the Feature Articles (homepage) or Category Blog (menu items).

    On this website, versions of Joomla and Joomlart template/plug-ins and other components/plug-ins were not current:

    Joomla! 3.8.2
    JA Magz II Template 1.0.4
    Plugin JA Content Type 1.1.1

    I went through and made sure all other components/plug-ins etc were updated. There was still no white space problems as with the live website. I then updated Joomla to 3.8.5 and again, no white space.

    Next I updated the JA template and plug-in. Again, no problems with white space, BUT it overwrote the custom PHP you provided where blog.php calls blog_leading.php or blog_item.php to display either the full image or intro image for the featured and category blog articles.

    So, I applied the custom changes AND still the white space is not displaying as it does on the live website.

    Hopefully this helps you address and resolve my support query.

    Regards, Robertf

    Saguaros Moderator
    #1095699

    Hi,

    You can override this by CSS:

    .leading-main, .leading-sidebar {
        min-height: 650px !important;
    }

    put into the file: root/templates/ja_magz_ii/css/custom.css (Create this file if it doesn’t exist)

    and change to the value which suits your need.

    rocher Friend
    #1095703

    Thanks, Saguaros, so min-height is not dynamically calculated for displaying the featured articles and category blog pages?

    Regards, Robertf

    • This reply was modified 9 months, 1 week ago by  rocher.
    rocher Friend
    #1095715

    Hi Saguaros,

    An update. Your CSS override didn’t work. However, in answering my own question on whether min-height is dynamically set (yes, by script.js), I discovered the problem was caused by JCH Optimize Pro.

    If I disabled the plug-in, min-height was correctly calculated and there was no extra white space. In the end, I added ja_magz-ii/js/script.js to the plug-in’s exclusion settings and this also worked as if the plug-in was disabled.

    HOWEVER, while doing all this, I’ve now noticed since yesterday’s upgrade I’ve lost Font Awesome settings. For instance, the social buttons and search icon in the header and the arrows for More in Category in the featured articles sections.

    I’ve tried disabling JCH Optimize, I’ve cleared all the caches, I’ve cleared the browser caches (Safari and Mozilla), but nothing’s worked.

    Could you PLEASE have a look at this for me asap?

    Thanks, Robertf


    1. tallandtrue-jchoptimize-setting
    rocher Friend
    #1095722

    Further update, Saguaros. Excluding script.js lead to JQuery errors, so I’ve had to disable the JCH Optimize plug-in. Still no sign of the Font Awesome icons … which is NOT awesome! 🙁

    rocher Friend
    #1095752

    Any ideas?

    rocher Friend
    #1095776

    Could someone please answer me!? I have lost Font Awesome icons on my live website having updated Joomla, Joomlart template and plug-ins and all other plug-ins to the latest release.

    What do I need to do to get back the functional, like social and search icons in the header?

    BTW, I pay an annual subscription of $67 for JATC Membership and I’m beginning to wonder why?

    Regards, Robertf

    Saguaros Moderator
    #1095945
    This reply has been marked as private.
    rocher Friend
    #1095992

    Sorry Saguaros, you guys have taken too long to respond to my query. I’ve had to reinstall and reset the admin links. I’ll sort it out by myself and I won’t be re-subscribing for template support.

    Regards,
    Robertf

Viewing 11 posts - 1 through 11 (of 11 total)

This topic contains 10 replies, has 2 voices, and was last updated by  rocher 9 months, 1 week ago.

We moved to new unified forum. Please post all new support queries in our New Forum