Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • p119foundation Friend
    #808731

    After installing the updated T3 plugin this morning, I started receiving HTTP 500 errors while using the back-end Joomla K2 item editor. Here is the PHP error causing the 500:
    PHP Fatal error: Cannot redeclare class T3Path in mysite/plugins/system/jat3/jat3/core/path.php on line 191

    p119foundation Friend
    #808768

    I figured out the issue.

    My Joomla site informed me that the T3 plugin needed to be updated, however, when I attempted to use the built-in update, it failed. Here’s why…

    The update site for T3 points to this XML for updating JoomlArt extensions: http://update.joomlart.com/service/tracking/list.xml

    That file points to this XML for updating the JA T3 System plugin: http://update.joomlart.com/service/tracking/j16/jat3.xml

    That file points to this URL for updating the plugin: [code]
    <downloadurl format="zip" type="full"> -<![CDATA[http://update.joomlart.com/service/download.php?element=plg_system_t3&version=2.5.2&type=plugin_16&coreVersion=j16]]>
    [/code]

    When I attempt to visit that URL I receive an error message:

    {"from":"JoomlArt Updater Service","to":"","content":{"error":"Response from JoomlArt Updater Service: Your account does not have enough permission to take this action. nttttttttPlease contact \"JoomlArt Updater Service\" for more information or use another account.","response":null}}

    Soooo… as a result of the error, I went to the "Downloads" section of the JoomlArt site and downloaded the T3 v2.7.0 plugin (what appeared to be the highest version of the plugin).

    This actually installed an old 2013 version of the plugin in addition to the current version which resulted in the PHP error. I uninstalled the old plugin version and everything worked again…. except the location of the plugin update.

    I manually went to the t3-framework.org site and downloaded the correct file.

    What needs to be done to get the downloadurl pointed to the correct location?

    Ninja Lead Moderator
    #811831

    Hi,

    In this case, I need to check this bug directly on your site, you can provide me the credentials info: FTP account, URL of your site and admin login info of your site by putting info in your reply and SET AS PRIVATE reply (so that only Moderators and Staffs can see). I will help you to check it further.

    Regards

Viewing 3 posts - 1 through 3 (of 3 total)

This topic contains 2 replies, has 2 voices, and was last updated by  Ninja Lead 3 years, 8 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum