favicon.ico - how many are there?? - JoomlArt
JA Brickstore template released More info
20% OFF this Halloween - coupon: JAHALLOBuy now
Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
  • planetstar Friend

    My favicon.ico is not showing. I am using the Puresite template on JAT3 2.0

    I get the Joomla favicon not matter what I do.

    I have placed my own blue star favicon in every template folder, just to be sure…

    I have placed it in the link in my soucefile:

    <link href=”/plugins/system/jat3/jat3/base-themes/default/images/favicon.ico” rel=”shortcut icon” type=”image/x-icon” />

    and I can look it up: http://stjerne.org/plugins/system/jat3/jat3/base-themes/default/images/favicon.ico and it shows ok.

    I have cleared the JAT3 cache more than 100 times, I have no caching enabled on the site, but just to be sure, I have purged and cleaned the Joomla cache.

    If I change theme to any of my other themes not based on JAT3 I get the correct icon.

    I have installed the Elastica JATC theme to. If i enable that theme, I get the Joomla favicon, too.

    If is disable JAT3 I get an error, but i get the correct icon

    If I request a page not being on the site, I get the correct icon on the 404 page.

    Can anyone tell me, where that black Joomla favicon.ico comes from???

    This is driving me nuts.

    swissa Friend

    <em>@planetstar 313482 wrote:</em><blockquote>
    This is driving me nuts.</blockquote>

    Know the feeling! The link you give STILL shows the black Joomla favicon too.

    The best advice I can give you is to delete the favicon completely using your ftp client and then install yours. That works for me always. Hope it helps you.

    planetstar Friend

    I have tried to remove all favicon.icon files in every template including the one in the JAT3 default theme, reset all cashes, made sure that I could the reach the favicon in the direct link – and the black Joomla icon shows up.

    If I search for favicon in this forum I get so many, many questions when JAT3 is involved. I have not been able to find any documentation especially not on why I have to go deep down in a framework to change a favicon file – the idea of frameworks is, that you should never think about it and be able to replace it with a new version and it should not change your site.

    I really, really don’t understand this.


    kiab Friend

    Ok managed to change it.

    I dont know which step were usefull but :

    Deleted All favicon.ico 1 by 1.
    Waited till the site show no favicon at all.
    Uploaded the right one in

    The 2nd time, it worked.

    winchester Friend

    <em>@kiab 314923 wrote:</em><blockquote>Ok managed to change it.

    I dont know which step were usefull but :

    Deleted All favicon.ico 1 by 1.
    Waited till the site show no favicon at all.
    Uploaded the right one in

    The 2nd time, it worked.</blockquote>

    There’s a better way to do this.

    1: Copy the “head.php” file from “/plugins/system/jat3/jat3/base-themes/default/blocks” to “templates/your_t3_template/blocks”

    2: open it up and look for the following line:
    <link href=”<?php echo T3Path::getUrl(‘images/favicon.ico’) ?>” rel=”shortcut icon” type=”image/x-icon” />

    3: Replace it with this line:
    <link href=”<?php echo JURI::base(true).”/templates/ja_t3_blank/favicon.ico”; ?>” rel=”shortcut icon” type=”image/x-icon” />
    Note that ja_t3_blank should be replaced with the name of your JA T3 folder’s name.

    3: Place your custom favicon file to your template folder; “templates/your_t3_template/favicon.ico”

    This way whenever you upgrade your template to a newer version, it doesn’t undo the change you made.

    Hope this helps.


    kiab Friend

    <blockquote>Hope this helps.

    Thank you (:

    contentera Friend

    It worked, thank you very much!!!!

    fchuks Friend

    God Bless you Winchester….Forza!

    ecspan Friend

    <em>@winchester 316597 wrote:</em><blockquote>There’s a better way to do this….

    …Hope this helps.


    Thank you, Winchester! This worked for me, too!😀

    realtoast Developer

    Wow! Thanks, winchester! I’m really surprised at the esoteric solution. But I’m really happen I found it and it works!

    mackdoyle Friend

    Or you could just replace the favicon link the the blocks/head.php with:

    <link href=”favicon.ico” rel=”shortcut icon” type=”image/x-icon” />

    And place the favicon.ico in the site root, where it’s supposed to be.

    Luiz FernandoMolina JATCJAEC

    Why does it have to be so complicated????

    Saguaros Moderator
    ilvmsc Friend

    Thank you! Worked flawlessly for me too!

    maxigran Friend

    It works. Thanks.

Viewing 15 posts - 1 through 15 (of 21 total)

This topic contains 21 replies, has 17 voices, and was last updated by  vicvin 2 years, 3 months ago.

You must be logged in to reply to this topic.