Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • ahmadharis Friend
    #968528

    Hi,

    After upgrading my joomla environment from 2.5 to 3.6 and installing a new JA Teline 5 template, I am getting an error

    All of my articles have the intro text duplicated. I am using the ja teline 5 template. Anytime the intro is displayed I get a duplicate article content

    This error only occurs in the JA Teline 5 template. Please help as it is affecting my production site.

    Saguaros Moderator
    #968640

    Hi

    You can update the URL and admin login info of your site and let us know the page where I can see the issue, I will check for you.

    ahmadharis Friend
    #968799
    This reply has been marked as private.
    Saguaros Moderator
    #969026

    You can try to disable the option "Show Intro Text" under Article Options in backend.

    ahmadharis Friend
    #969199
    This reply has been marked as private.
    Saguaros Moderator
    #969335

    The introtext and fulltext of an article will be separated by Readmore button, so you can go to backend settings of article and place the Readmore button as you wish.

    aardcom Friend
    #1008813

    I have the same issue only on the Events page when viewing an event. I don’t want to turn off the default setting for Joomla which is to display introtext (before readmore) in an intro, but I do want to turn it off the setting in an events view so it does not dislay twice. Is this in a ACM setting?

    Maybe someone could fix this in the template quickstart for new downloads.

    Saguaros Moderator
    #1008919

    Hi,

    You can share the URL and admin login info and tell me the page you want to turn off the intro text. I will take a look.

    Regards

    aardcom Friend
    #1009160

    I appreciate that but I do not have the site online. I can confirm it is in the quickstart package and is viewable in the online demo as well.
    If you open the demo and then select the Events tab at the top and then selct an event to view the details you will see the intro text is repeated, first in a large font and then in regular font. I believe it is formatted as quoted text.
    I would assume the preference would be larger introtext font and then the remaining part of the article in standard font, not duplicated intro text.

    Please let me know where this can be changed and then I’d suggest changing it in the quickstart and the demo.


    1. screen
    Saguaros Moderator
    #1009219

    Hi,

    If you don’t want to use the settings to hide the introtext in article page, you can access this file: ROOT/templates/ja_teline_v/html/layouts/joomla/content/item/event.php

    Remove this snippet of code which renders the introtext:

    <?php if ($aparams->get('show_intro', 0)) : ?>
        <blockquote class="article-intro" itemprop="description">
            <?php echo $item->introtext; ?>
        </blockquote>
    <?php endif; ?>

    Regards

    aardcom Friend
    #1009350

    I would like to keep the introtext in a blockquote format, as it is in all other sections, but instead remove the introtext from appearing a second time in regular font.

    I also believe this is an error in the template that needs to be corrected, since all other sections do not duplicate the intro text, and I can see no reason anyone else would want this to occur.

    Of course in the case of it being a blockquote there maybe times where someone would wish to emphasis text, and have the quote appear a second time for emphasis, however as it is being used in this case, it is not correct. And since it is not the same as all other articles outside of EVENTS section, I assume there is an easy way to fix this.

    Saguaros Moderator
    #1009399

    Hi,

    You could try this way:

    • Go to menu item of Event page on your site, for example, the ‘Events’ item in top navigation in our demo site >> access ‘Options’ tab and hide the introtext: http://prntscr.com/e6sot0

    • Open the file: ROOT/templates/ja_teline_v/html/layouts/joomla/content/item/event.php

    • Change this:
      <?php if ($aparams->get('show_intro', 0)) : ?>
      <blockquote class="article-intro" itemprop="description">
          <?php echo $item->introtext; ?>
      </blockquote>
      <?php endif; ?>

    To:

        <blockquote class="article-intro" itemprop="description">
            <?php echo $item->introtext; ?>
        </blockquote>

    This way will keep introtext in blockquote format and not be duplicated.

    Regards

    aardcom Friend
    #1009789

    I do not wish to ‘hide’ introtext. I want to show it highlightsd as in a blockquote format. Once per article.

    Saguaros Moderator
    #1009919

    Did you try to follow my above suggestion? It will show introtext in highlighted quote

    aardcom Friend
    #1011705

    Tried but it still has double introtext. Once in blockquote and then again in regular article font

Viewing 15 posts - 1 through 15 (of 20 total)

This topic contains 19 replies, has 4 voices, and was last updated by  Saguaros 2 years, 7 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum