Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • ejbjane Friend
    #1063111

    After upgrading Joomla to 3.8 from 3.75 I have errors and the website is down. This website is still in production so it only has one other third party component which is not the problem. It’s a very new site and the first Joomla install was 3.75 as I recall.

    I also posted this on https://forum.joomla.org/viewtopic.php?f=710&t=954856 – Someone seems to think this is about the T3 Framework Plugin. I do not know. I have applied databse fix and upgrade to PHP 7.0 and, permissions etc. and it’s not fixing itself.

    The problem is as follows :

    Backend : 0 Call to undefined method JModuleHelper::isAdminMultilang() /home1/grantour1/public_html/administrator/components/com_menus/controller.php:34

    Full error report: Call stack

    Function Location

    1 () JROOT/administrator/components/com_menus/controller.php:34 2 MenusController->display() JROOT/libraries/src/MVC/Controller/BaseController.php:710 3 JoomlaCMSMVCControllerBaseController->execute() JROOT/administrator/components/com_menus/menus.php:18 4 require_once() JROOT/libraries/src/Component/ComponentHelper.php:392 5 JoomlaCMSComponentComponentHelper::executeComponent() JROOT/libraries/src/Component/ComponentHelper.php:367 6 JoomlaCMSComponentComponentHelper::renderComponent() JROOT/libraries/src/Application/AdministratorApplication.php:101 7 JoomlaCMSApplicationAdministratorApplication->dispatch() JROOT/libraries/src/Application/AdministratorApplication.php:159 8 JoomlaCMSApplicationAdministratorApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:267 9 JoomlaCMSApplicationCMSApplication->execute() JROOT/administrator/index.php:51

    ALSO

    Frontend: Fatal error: Cannot declare class JModuleHelper, because the name is already in use in /home1/grantour1/public_html/plugins/system/t3/includes/joomla30/modulehelper.php on line 19

    Perhaps you could check these errors and get back to me. The website is at http://www.grantourinitalia.nl

    Khanh Le Moderator
    #1063115

    Hi ejbjane,
    First, I suggest that you should always try to upgrade on a staging or dev site before apply it to production.
    For the T3 on Joomla 3.8, I did make an upgrade test for T3 Blank and it works fine. In your case, there should be a conflict between T3 and one of your third party extension. Please share with me (set as Private reply) your site administrator account as well as ftp login then I can take a check on your site.
    Thanks,

    newty505 Friend
    #1063120

    I seem to be suffering the same error here, however in my instance it related to the administrator/components/com_menus/controller.php file, instead of the t3 plugin as your error would suggest. The issue seemed to be relating to an if statement, which I have since commented out. This has temporarily fixed the issue, however is obviously far from an ideal solution to the problem. If you get any further into resolving the issue, I’d love to know what you did, as I am now stuck with being unable to edit any menus, and obviously can’t push this to my production server yet.

    ejbjane Friend
    #1063130

    That’s only the Frontend error, I am in fact more worried about the Menu item error. I can’t make the assessment that it is the same thing.

    sparkktv Friend
    #1063161

    There is a menu issue. I haven’t updated my live site yet but in localhost for example if I choose a menu item alias, it gives me an error when I try to choose the menu item. But I do not believe it’s caused by Joomlart, it’s a Joomla issue possibly with the new router id’s. I was able to get around it by editing manually in phpmyadmin. But you have to be very careful doing it that way.

    ejbjane Friend
    #1063172

    Please see topic https://github.com/joomla/joomla-cms/issues/18003
    If you scroll down you can see that the error turns up with T3 on other websites.

    charles99 Friend
    #1063184

    I would like to know if it safe to upgrade to joomla 3.8 with T3 installed or should we wait for a fix from Joomlart…. It seem to be a Framework Issue that people are running into. And work around can cause more problem than the one people are having now…

    So can someone from Joomlart recommend what people should do before they end up messing up their website! And to make sure it a T3 Problem switch your template and disable T3 Plug to seem if the problems go away… If so than T3 is the problem… But I intend to wait until Joomla 3.8.1 come out with all the minor fixes….

    • This reply was modified 2 years, 10 months ago by  charles99.
    Khanh Le Moderator
    #1063252

    @ejbjane: I made a fix on T3 to make it compatible with Joomla 3.8. Your site works well on frontend now. The menu issue on backend is come from NS FontAwesome Pro plugin.

    • This reply was modified 2 years, 10 months ago by  Khanh Le.
    • This reply was modified 2 years, 10 months ago by  Khanh Le.
    ejbjane Friend
    #1063262

    Great, thanks Khanh Le ! I have disabled font-awesome for now and will advise the developer. Otherwise, do you think it is safe to upgrade other sites using T3? As charles99 asked also.

    Khanh Le Moderator
    #1063266

    You should always backup your site, test thoroughly in a staging environment before apply the upgrade in production site.

    nandapeter Friend
    #1063316

    I have a close problem, all the pages created through menu items cannot open from mobile devices. I am getting blue screen. the modules are loading though the main body is not unless i put the phone on landscape.
    https://www.literaturereviewhelp.com/dissertation-chapter-help
    The pages from joomla articles linked directly though are working fine.

    I am using ja nex template.

    original.com Friend
    #1063334

    any sollutions for the issue :

    Fatal error: Cannot declare class JModuleHelper, because the name is already in use in /home/xxxx/public_html/plugins/system/t3/includes/joomla30/modulehelper.php on line 19
    after updating to joomla 3.8

    ???

    B.T.

    charles99 Friend
    #1063335

    It doesn’t matter what template you are using because they all work on the T3 Framework… Each template is running into different problems as you can see in this post.

    Again, can someone at Joomlart let people know if we should wait for a T3 Framework Fix..? Because disabling font-awesome on one template may not be the answer for another template. And Joomlart T3 framework is not the only one thats not working right with Joomla 3.8.. their are a number of plugins and components that have not been updated. So take this time to find and replace them while Joomlart fiind a fix for their T3 Framework.

    Khanh Le Moderator
    #1063431

    We are working hard to release update for T3 then you could upgrade to Joomla 3.8.

    duplexau Friend
    #1064062

    @ejbjane: I made a fix on T3 to make it compatible with Joomla 3.8. Your site works well on frontend now. The menu issue on backend is come from NS FontAwesome Pro plugin.

    Hi I also experienced this error in one of sites. However my case was different to @ejbjane‘s, I seem could not find the NS FontAwesome Pro plugin (which was suggested by @khanhlh) in backend and I didn’t think the site uses font awesome plugin.

    The plugin version for T3 framework used in the site is 2.6.7.

    Any suggestions would be greatly appreciated

Viewing 15 posts - 1 through 15 (of 19 total)

This topic contains 18 replies, has 12 voices, and was last updated by  Saguaros 2 years, 10 months ago.

We moved to new unified forum. Please post all new support queries in our New Forum