Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • mengler12 Friend
    #1090172

    Hello,

    I am working with the JA Small Biz template and would like to affix a custom module at the bottom of the page.

    Currently, when I scroll to the bottom of the page, it appears and functions as I want it to both in small screens and large. See screenshot.

    The module name is "Masthead-footer," and is in the "debug" position.

    I would like to know what the custom CSS code is to accomplish this.

    Thanks,
    Peter


    1. Screenshot-2018-2-5-Home-North-West-Consulting-
    Saguaros Moderator
    #1090248

    Hi Peter,

    You will need to add that custom module a div with container class:

    <div class="container-lg"> .... </div>

    I added for you and this custom CSS also:

    //sticky bottom
    
    .custom.stick {
      position: fixed;
      bottom: 0;
    }

    in ‘custom.css’ file, you can check it now.

    Regards

    mengler12 Friend
    #1090345

    Hi Saguaros,

    Thanks for helping with that. But it is still not "Sticky’

    Am I doing something wrong? Could you check the module.

    Saguaros Moderator
    #1090346

    Maybe cache from your browser? could you try to clear it?

    mengler12 Friend
    #1090357

    I did that and also checked on multiple devices. iPhone, PC, laptop and with different browsers
    Still not sticky.

    Saguaros Moderator
    #1090495

    Is there any cache from server side?

    As you can see in the custom.css file, I add ‘display: none’ property for this module but no change. So I guess there must be the cache somewhere on your site or in server side.

    mengler12 Friend
    #1090586

    Hi Saguaros,

    Yes, I have seen those changes you mention. Thank you for helping with that. I have flushed the server cache and all browser cache.

    However, there still is no change in the site.

    What now?

    Saguaros Moderator
    #1090599

    I think that there maybe cache settings in server side, some hosts have this cache always enabled. Pls try to contact your hosting provider if there is any one like that.

    mengler12 Friend
    #1090602

    should I set it to "off"

    mengler12 Friend
    #1090604

    I went ahead and shut the server cache to "off"

    flushed the browsers, checked multiple devices. still nothing changed.

    Saguaros Moderator
    #1090731
    This reply has been marked as private.
    mengler12 Friend
    #1090805
    This reply has been marked as private.
    Saguaros Moderator
    #1091026

    That’s it! The SuperCacher is enabled on your server, I disabled it and you can see the module sticky on footer now. http://prntscr.com/icafri

Viewing 13 posts - 1 through 13 (of 13 total)

This topic contains 12 replies, has 2 voices, and was last updated by  Saguaros 6 months, 1 week ago.

We moved to new unified forum. Please post all new support queries in our New Forum