Upgrading php 5.2 to php 5.3 - JoomlArt
JA Restaurant template released More info
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • boizan JATCJAEC
    #176087

    Hello,
    I just upgraded php 5.2 to 5.3 on my hosting account. Now (just five minutes after the change) all my web sites, which are running only JA templates, are giving this error
    “Internal Server Error: The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log.”
    Is there anything I could do to fix this problem? I would like to keep using php 5.3 as there are new components that require php 5.3.
    I would appreciate very much your help.
    Thanks,

    swissa Friend
    #448301

    Hi

    I don’t know if this will help and your hosting company should be able to point you in the right direction but when I upgraded from 5.2.7 to 5.3.4 I needed to add some code into my php.fcqi and .htaccess files.

    You might want to check with them if you need to do the same especially if they are running multiple versions of php on their servers.

    boizan JATCJAEC
    #448326

    Hello,
    Thank you so much for your reply. I searched this problem on Joomla forum and found a few entries, but not solution was offered. Here I posted it thinking in JA templates requirements. I contacted Godaddy after the problem, but the agent could not help. He just suggested going back to Php 5.2. I will contact them again to see if I get in touch with a more knowledgeable technician. Again, thanks!

    swissa Friend
    #448368

    Gerne

    From what I hear, Godaddy is on of the worst hosting company. They allow you to do so little. Perhaps look to change but with php it is not easy anyway if your hosting company has many live options.

    This is what I did (sorry is in German)

    Erstellen der .htaccess Datei mit folgendem Inhalt:
    AddHandler php5-fastcgi .php .php5

    Öffnen Sie die Datei php.fcgi zur Bearbeitung.
    Nehmen Sie auf Zeile 3 folgende Anpassung vor:

    bestehend (PHP 5.2)
    PHP_CGI=/usr/bin/php-cgi

    neu (PHP 5.3)
    PHP_CGI=/opt/php53/bin/php-cgi

    Ask if Godaddy have something similar.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic contains 4 replies, has 2 voices, and was last updated by  swissa 4 years, 5 months ago.

You must be logged in to reply to this topic.