1. ***HOT*** August Responsive Joomla template for Application Landing page - JA Nuevo [Sneak Peek]


    JM TravelGear - Responsive Magento theme for outdoor activities gear stores [Sneak Peek]


    *Release 8 more tutorial videos on developing with T3 Framework* See them here!


    July Responsive Joomla template - JA Playmag is here [Demo] [Download] [More info] [Blog Review]


User Tag List

+ Reply to Thread
 
Results 1 to 1 of 1
  1. #1

    Joomla Developer Membership - Renew 1 year Expired
    toymaker's Avatar
    Join Date
    Apr 2010
    Location
    Santiago, Chile
    Posts
    123
    Points
    1,609.44
    Downloads
    220
    Uploads
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks
    9
    Thanked 53 Times in 43 Posts

    Lightbulb "open_basedir restriction in effect" error on Sites using Plesk

    Some of you might be having this error showing up... I got this error when updating extensions with Extension Manager, but you could experience the same error under different conditions. If you use a Plesk enabled hosting provider or you ARE a hosting provider and Parallels partner like me, heres the fix

    This error shows up because of the way Plesk manages security for all Vhosts, so the way to fix this, is to create a specific vhost.conf file for the site that has Joomla and Extensions Manager enabled.

    Open your vhost.conf file or create one if you dont already have one.
    /var/www/vhosts/your.domain/httpdocs

    ... and insert the following code...

    Code:
    <Directory /var/www/vhosts/your.domain/httpdocs>
    	        <IfModule sapi_apache2.c>
    	                php_admin_flag engine on
    	                php_admin_flag safe_mode off
    	                php_admin_value open_basedir "/var/www/vhosts/your.domain/httpdocs:.:/php:/tmp"
    	        </IfModule>
    	        <IfModule mod_php5.c>
    	                php_admin_flag engine on
    	                php_admin_flag safe_mode off
    	                php_admin_value open_basedir "/var/www/vhosts/your.domain/httpdocs:.:/php:/tmp"
    	        </IfModule>
    	</Directory>
    Reconfigure the domain using the httpdmng command... restart the httpd service and thats it! Problem fixed.

    Hope it helps.

    Peace,
    Gabriel

  2. The Following User Says Thank You to toymaker For This Useful Post:

    drarvindc (11-23-2010)

+ Reply to Thread

Similar Threads

  1. Replies: 0
    Last Post: 05-11-2010, 07:38 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Stop working on Weekend!X

If your Boss broke your Joomla template or extension and ask you to fix it today. Here is the immediate solution. Then leave your request on the right forum, we will be helping after the Weekend Happy hours
Our Happy Hours: Friday 18:00 - Monday 9:00

No working during happy hours. Keep calm and don't break anything.